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Creating a Processor System Lab

Introduction

This lab introduces a design flow to generate a IP-XACT adapter from a design using Vivado HLS and
using the generated IP-XACT adapter in a processor system using IP Integrator in Vivado.

Objectives

After completing this lab, you will be able to:

e Understand the steps and directives involved in creating an IP-XACT adapter from a synthesized
design in Vivado HLS

e Create a processor system using IP Integrator in Vivado

¢ Integrate the generated IP-XACT adapter into the created processor system

The Design

The design consists of a FIR filter to filter a 4 KHz tone added to CD quality (48 KHz) music. The
characteristic of the filter is as follows:

FS=48000 Hz

FPASS1=2000 Hz

FSTOP1=3800 Hz

FSTOP2=4200 Hz

FPASS2=6000 Hz

APASS1=APASS2=1 dB

ASTOP=60 dB

This lab requires you to develop a peripheral core of the designed filter that can be instantiated in a
processor system. The processor system will acquire a stereo music stream using an on-board CODEC
chip and 12C controller, process it through the designed filter (bandstop filter), and output back to the
headphone.

Procedure

This lab is separated into steps that consist of general overview statements that provide information on
the detailed instructions that follow. Follow these detailed instructions to progress through the lab.

This lab comprises 14 primary steps: You will create a new project in Vivado HLS, run simulation,
synthesize the design, run RTL/C co-simulation, create a project in Project Navigator, run simulation
using ISIM, setup for IP-XACT adapter in Vivado HLS, implement the design in Vivado HLS, create a
processor system in Vivado using IP Integrator, create a software application in SDK, and verify the
design in hardware.
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General Flow for this Lab

Step 1: Step 2: Step 3: Step 4: Step 5:
Create a Run C Synthesize Run RTL/C Setup IP-
New :> Simulation |:> the Design :> Co- :> XACT
Project Simulation Adapter
Step 6: Step 7: Step 8: Step 9: Appendix:
Generate Create a Export to Verify the Create an
the IP-XACT |:> Vivado |:> SDK & |:> Sesc;gn in |:> Initial D?I_S||gn
Adapter Project Create an ardware using Tc
Annlication Script
Create a New Project Step 1

1-1. Create a new project in Vivado HLS targeting XC72020CLG484-1
(ZedBoard) or XC7Z010CLG400-1 (Zybo).

1-1-1. Launch Vivado HLS: Select Start > All Programs > Xilinx Design Tools > Vivado 2014.4 >
Vivado HLS > Vivado HLS 2014.4

A Getting Started GUI will appear.

1-1-2. In the Getting Started section, click on Create New Project. The New Vivado HLS Project wizard
opens.

1-1-3. Click Browse... button of the Location field, browse to ¢:\xup\hls\labs\lab4, and then click OK.
1-1-4. For Project Name, type fir.prj
1-1-5. Click Next.

1-1-6. In the Add/Remove Files for the source files, type fir as the function name (the provided source
file contains the function, to be synthesized, called fir).

1-1-7. Click the Add Files... button, select fir.c and fir_coef.dat files from the ¢:\xup\hls\labs\lab4 folder,
and then click Open.

1-1-8. Click Next.

1-1-9. In the Add/Remove Files for the testbench, click the Add Files... button, select fir_test.c file from
the c:\xup\hls\labs\lab4 folder and click Open.

1-1-10. Click Next.

1-1-11. In the Solution Configuration page, leave Solution Name field as solution1 and set the clock
period as 10 (for ZedBoard) or 8 (for Zybo). Leave Uncertainty field blank as it will take 1.25 as
the default value for ZedBoard and 1 for Zybo.
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1-1-12.

1-1-13.

1-1-14.

1-1-15.

Click on Part’s Browse button, and select the following filters, using the Parts Specify option, to
select xc72020clg484-1 (ZedBoard) or xc7z010clg400-1 (Zybo), and click OK:

Family: Zynq

Sub-Family: Zynq

Package: clg484 (ZedBoard) or ¢lg400 (Zybo)

Speed Grade: -1

Click Finish.

You will see the created project in the Explorer view. Expand various sub-folders to see the
entries under each sub-folder.

Double-click on the fir.c under the source folder to open its content in the information pane.

1#include "fir.h"
2

3void fir (

4  data_t *vy,

5 data_t x

6 )4

7 const coef_t c[N+1]={

8 #include "fir coef.dat”

9 };

12  static data t shift_reg[N];

13 acc_t acc;

14 int i;

15

16 acc=(acc_t)shift_reg[N-1]*(acc_t)c[N];
17 loop: for (i=N-1;il!=@;i--) {

18 acc+=(acc_t)shift_reg[i-1]*(acc_t)c[i];
19 shift_reg[i]=shift_reg[i-1];

28 %

21 acc+=(acc_t)x*(acc_t)c[@];

22 shift_reg[@]=x;

23 *y = acc >» 15;

24 %

Figure 1. The design under consideration

The FIR filter expects x as a sample input and pointer to the computed sample out. Both of them
are defined of data type data_t. The coefficients are loaded in array c¢ of type coef_t from the file
called fir_coef.dat located in the current directory. The sequential algorithm is applied and
accumulated value (sample out) is computed in variable acc of type acc_t.

Double-click on the fir.h in the outline tab to open its content in the information pane.
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1-1-16.

1#ifndef FIR H_
) #define FIR H_

3 #include "ap_cint.h"

A #define N 58

5 #define SAMPLES N+1@ // just few more samples then n
6typedef short coef t;

7 typedef short data_t;

Ztypedef inti8 acc t;

9 #endif

kl

m
E
=
m
=
(=]

Figure 2. The header file

The header file includes ap_cint.h so user defined data width (of arbitrary precision) can be used.
It also defines number of taps (N), number of samples to be generated (in the testbench), and
data types coef_t, data_t, and acc_t. The coef_t and data_t are short (16 bits). Since the
algorithm iterates (multiply and accumulate) over 59 taps, there is a possibility of bit growth of 6
bits and hence acc_t is defined as int38. Since the acc _t is bigger than sample and coefficient
width, they have to cast before being used (like in lines 16, 18, and 21 of fir.c).

Double-click on the fir_test.c under the testbench folder to open its content in the information
pane.

Notice that the testbench opens fir_impulse.dat in write mode, and sends an impulse (first sample
being 0x8000.

Run C Simulation Step 2

2-1.

2-1-1.

Run C simulation to observe the expected output.

Select Project > Run C Simulation or click on * from the tools bar buttons, and Click OK in
the C Simulation Dialog window.

The testbench will be compiled using apcc compiler and csim.exe file will be generated. The
csim.exe will then be executed and the output will be displayed in the console view.
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Starting C simulation ...

C:/¥Xilinx/Vivado HLS/2014.4/bin/vivado_hls.bat C:/xup/hls/labs/labd/fir.prj/solutionl/csim.tcl

@I [LIC-101] Checked out feature [HLS]

@I [HLS-1@] Running 'C:/Xilinx/Vivado HLS/2014.4/bin/unwrapped/win64.o/vivado hls.exe’
for user 'parimalp’ on host 'xsjparimalp3@’ (Windows NT_ amd64 version 6.1) on Wed :
in directory 'C:/xup/hls/labs/lab4’

@I [HLS-18] Opening project 'C:/xup/hls/labs/labd/fir.prj’.

@I [HLS-1@] Opening solution 'C:/xup/hls/labs/labd/fir.prj/solutionl’.

@I [SYN-201] Setting up clock "default’ with a period of 8ns.

@I [LIC-101] Checked out feature [HLS]

@I [HLS-10] Setting target device to 'xc7z@l@clgd@e-1'

Compiling(apcc) ../../../../fir_test.c in debug mode

@I [LIC-181] Checked out feature [HLS]

@I [HLS-1@] Running 'c:/Xilinx/Vivado HLS/2014.4/bin/unwrapped/winé4.o/apcc.exe’
for user 'parimalp’ on host 'xsjparimalp3@’ (Windows NT_amd64 version 6.1) on Wed :
in directory 'C:/xup/hls/labs/lab4d/fir.prj/solutionl/csim/build”’

@I [APCC-3] Tmp directory is apcc_db

@I [APCC-1] APCC is done.

@I [LIC-1081] Checked in feature [VIVADO_HLS]
Generating csim.exe

B -32768 378

18 73

20 -27

309 -170

4 @ -298

5 8 -352

6 0 -302

7 B -168

820 -14

9 0 80

10 6 64

11 & -53

12 6 -186

13 8 -216

14 6 -40

15 @ 356

16 @ 867

17 @ 1283

18 6 1366

Figure 3. Initial part of the generated output in the Console view

You should see the filter coefficients being computed.

Synthesize the Design Step 3

3-1.

Synthesize the design with the defaults. View the synthesis results and
answer the question listed in the detailed section of this step.

3-1-1. Select Solution > Run C Synthesis > Active Solution to start the synthesis process.
3-1-2. When synthesis is completed, several report files will become accessible and the Synthesis
Results will be displayed in the information pane.
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3-1-3. The Synthesis Report shows the performance and resource estimates as well as estimated
latency in the design.

3-1-4. Using scroll bar on the right, scroll down into the report and answer the following question.

Question 1

Estimated clock period:

Worst case latency:

Number of DSP48E used:

Number of BRAMs used:

Number of FFs used:

Number of LUTs used:

3-1-5. The report also shows the top-level interface signals generated by the tools.

Interface

- Summary
RTLPorts Dir Bits Protocol Source Object C Type
ap_clk in 1 ap_ctrl_hs fir  return value
ap_rst in 1 ap_ctrl_hs fir  return value
ap_start in 1 ap_ctrl_hs fir  return value
ap_done out 1 ap_ctrl_hs fir  return value
ap_idle out 1 ap_ctrl_hs fir  return value
ap_ready out 1 ap_ctrl_hs fir  return value
¥ out 16 ap_vld ¥ pointer
y_ap_vid out 1 ap_vid y pointer
X in 16 ap_none X scalar

Figure 4. Generated interface signals

You can see the design expects x input as 16-bit scalar and outputs y via pointer of the 16-bit
data. It also has ap_vld signal to indicate when the result is valid.

3-2. Add PIPELINE directive to loop and re-synthesize the design. View the
synthesis results.

3-2-1. Make sure that the fir.c is open in the information view.

3-2-2. Select the Directive tab, and apply the PIPELINE directive to the loop.

3-2-3. Select Solution > Run C Synthesis > Active Solution to start the synthesis process.

3-2-4. When synthesis is completed, the Synthesis Results will be displayed in the information pane.
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3-2-5. Note that the latency has reduced to 63 clock cycles. The DSP48 and BRAM consumption
remains same; however, LUT and FF consumptions have slightly increased.

Run RTL/C CoSimulation Step 4

4-1. Run the RTL/C Co-simulation, selecting SystemC and skipping VHDL and
Verilog. Verify that the simulation passes.

4-1-1. Select Solution > Run C/RTL Cosimulation or click on the ¥ button to open the dialog box
so the desired simulations can be run.

A C/RTL Co-simulation Dialog box will open.

4-1-2. Select the SystemC option and click OK.
The Co-simulation will run, generating and compiling several files, and then simulating the design.

In the console window you can see the progress. When done the RTL Simulation Report shows
that it was successful and the latency reported was 63.

Setup IP-XACT Adapter Step 5

5-1. Add RESOURCE directives to create AXI4LiteS adapters so IP-XACT
adapter can be generated during the RTL Export step.

5-1-1. Make sure that fir.c file is open and in focus in the information view.

5-1-2. Select the Directive tab.

5-1-3. Right-click x, and click on Insert Directive....

5-1-4. In the Vivado HLS Directive Editor dialog box, select INTERFACE using the drop-down button.
5-1-5. Click on the button beside mode (optional). Select s_axilite.

5-1-6. In the bundle (optional) field, enter fir_io and click OK.
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r

+ | Vivado HLS Directive Editor

Directive

INTERFACE

Destination

() Source File
@) Directive File
Options

mode (optional):

register (optional):

depth (optional):

port (required):

offset (optional):

bundle (optional):

s_axilite

fir_io

Help J [

Cancel

OK

N

Figure 5. Selecting the AXI4LiteS adapter and naming bundle

5-1-7. Similarly, apply the INTERFACE directive (including bundle) to the y output.
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5-1-8.

| Vivado HLS Directive Editor

X

Directive

INTERFACE

Destination
Source File

Q) Directive File

Options

mode (optional):

register (optional):

depth (optional):

port (required):

offset (optional):

bundle (optional):

s_axilite

fir_io

Help | {

OK

/

Figure 6. Applying bundle to assign y output to AXl4Lite adapter

Apply the INTERFACE directive to the top-level module fir to include ap_start, ap_done, and
ap_idle signals as part of bus adapter (the variable name shown will be return). Include the
bundle information too.
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+ | Vivado HLS Directive Editor S

Directive

INTERFACE v

Destination
Source File
Q) Directive File

Options

mode (optional): s_axilite v

register (optional):

depth (optional):

offset (optional):

bundle (optional): fir_io

Help ’ ‘ Cancel J [ OK

\ /

Figure 7. Applying bundle to assign function control signals to AXI4Lite adapter

Note that the above steps 5-1-3 through 5-1-8 will create address maps for x, y, ap_start ap_valid,
ap_done, and ap_idle, which can be accessed via software. Alternately, ap_start, ap_valid,
ap_done, ap_idle signals can be generated as separate ports on the core by not applying
RESOURCE directive to the top-level module fir. These ports will then have to be connected in a
processor system using available GPIO IP.
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Generate IP-XACT Adapter

Step 6

6-1. Re-synthesize the design as directives have been added. Run the RTL
Export to generate the IP-XACT adapter.

6-1-1. Since the directives have been added, it is safe to re-synthesize the design. Select Solution >
Run C Synthesis > Active Solution.

6-1-2. Once the design is synthesized, select Solution > Export RTL to open the dialog box so the

desired IP can be generated

An Export RTL Dialog box wi

ill open.

+' | Export RTL Dialog

_x

Export RTL

Format Selection

IP Catalog

v ’ ‘ Configuration...

Options

| Evaluate |Verilog

| Do not show this dialog box again. |

OK l ‘ Cancel

Figure 8. Export RTL Dialog

6-1-3. Click OK to generate the IP-XACT adapter.

6-1-4. When the run is completed, expand the impl folder in the Explorer view and observe various

generated directories; ip, ve

rilog and vhdl.
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4 = impl
=21
» = verilog
» = vhdl

Figure 9. IP-XACT adapter generated

Expand the ip directory and observe several files and sub-directories. One of the sub-directory of
interest is drivers directory which consists of header, c, tcl, mdd, and makefile files. Another file of
interest is the zip file, which is the ip repository file that can be imported in an IP Integrator design

4 (= ip
= autoimpl.log
= auxiliary.xml
=l componentxml
=| packbat
@ run_ippack.tcl
= vivado.jou
=l vivado.log
=| xilinx_com_hls_fir 1 _0.zip

+ ¥ constraints
= bd
» = doc

4 (= drivers
4 = firvl 0
4 (= data
= firmdd
o firtcl
4 (= sr¢
Makefile
Ll xfir_hw.h
Lel afir_linux.c
Ll xfir_sinit.c
L] xfir.c
le| xfirh
» example
hdl
misc

» subcore

T VT (T Y

xgui

Figure 10. Adapter’s drivers directory

6-1-5. Close Vivado HLS by selecting File > Exit.
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Create a Vivado Project

Step 7

7-1.

Launch Vivado Tcl Shell and run the provided tcl script to create an initial

system targeting either the Zedboard (having xc7z020clg484-1 device) or
Zybo (having xc7z010clg400-1 device).

If you want to create the system from scratch then follow the steps
provided in Appendix and then continue from step 7-2 below.

2014.4 > Vivado 2014.4 Tcl Shell

peripherals by typing the following command:

source zed_audio_project_create.tcl for ZedBoard or

source zybo_audio_project_create.tcl for Zybo

In the shell window, change the directory to c./xup/his/labs/lab4 using the ed account.

Run the provided script file to create an initial system having zed_audio_ctrl and GPIO

The script will be run and the initial system, shown below, will be created.

processing_system?_0

SDATAI[

DDR4 || ===} DDR
FIXED_IO 4 || =) FIXED_1O
ZYNQ‘ 1C_t 4 ||p———D) 1C_1
M_AXI_GPO_ACLK M_AX]_GPO - iy
' FCLK_CLKD
FCLK_CLKL {3 FCLK_CLK1
FCLK_RESETO_N F7
ZYNQ7 Processing System
axi_gpio_0
rst_processing_system7_0_100M processing_system7_0_axi_periph St
45 AXI
slowest_sync_clk mb_reseti - . GPIO || prmeeeeee——{™ GPIO
ext_reset_in bus strct resetf0:0) 2L e GPI02 4 || 7, GPTO2
au_reset_in peripheral_resef[0:0]m
§ TN ——
imb_debug sys rst  interconnect_aresetn[ 0:0) e o0 ack DMDG ed D ed,;:qdemo |
jdem_locked peripheral ¢ e D§Dmufmx zed_audio_ctrl_0
Processor System Reset MOO_ACLK &g s dRsma B—— Ty ECK
b——MOD_ARESETN TA_T e iréie
—
MOL_ACLK S AXIACLK
- =il SDATA_Op——————————— 3 SDATA O
b—M01_ARESETN 5 AXI_ARESETN 9 =
AXT Interconnect e R

Open Vivado Tcl Shell by selecting Start > All Programs > Xilinx Design Tools > Vivado

Figure 11. Block design having zed_audio_ctrl and connections made for ZedBoard

processing_system?_0

M_AXI_GPO_ACLK ZYNQ‘

DDRefr || ===} DDR
FIXED_10 ||| ™3 FIXED_IO

ZYNQ7 Processing

System

RECDAT [

rst_processing_system?7_0_100M

processing_system7_0_axi_periph

islowest_sync_clk mb_reset

axi_gpio_0

GPIO4= w"—D GPIO

C | ds00_axt _axi_adk
ext reset_in bus_struct reset{0:0]p= o GPI02 | e} GPI02
——=ACLK ;_axi_aresetn
aux _reset_in peripheral_reset[0:0] s e
mb_debug sys rst  interconnect_aresetn[0:0] pmeml 00 ACLK AXI GPIO
dem_locked ripheral = MOO_AXT o |t io_ctrl_0
| peripheral ¢ o e Démmﬂmz ; zybo_audio_ctrl_
Processor System Reset MOO_ACLK [, an - 4=S_AXI BOLKp———————{ 5 BCLK
p—i{100_ARESETN RECDAT PBLRCLK pe————————————— ™ PBLRCLK
M01_ACLK _AXIACLK  RECLROLK|———— ™5 RECLRCLK
p——M01_ARESETN  AXL_ARESETN ~ PBDATAp———— [ PBDATA

AXT Interconnect

zybo_audio_ctrl

Figure 11. Block design having zybo_audio_ctrl and connections made for Zybo
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7-2. Add the HLS IP to the IP Catalog
7-2-1. In the Flow Navigator pane, click Project Settings under Project Manager.
7-2-2. Click the IP icon.
7-2-3. Click the Add Repository... button. Browse to c:\xup\hls\labs\lab4\fir.prj\solution\impl\ip
and click Select.
The directory will be scanned and added in the IP Repositories window, and Fir IP entry will be
displayed in the IP in Selected Repository window.
r ¢~ Project Settings ﬁ
) i P
ﬁ) Repository Manager | Packager
General (@ Add directories to the list of repositories. You may then add additional 1P
& to a selected repository. If an IP is disabled then a tool-tip will alert you to
the reason.
Simulation IP Repositories
' & c:/xup/hls/labs/lab4/ip_repo (Project I
/ , c:/xup/hls/labs/lab4/fir.prj/solution1/impl/ip (Project) =
Synthesis
D [ Add Repository... ] [ Refresh All }
Implementation ~~ ———— =
P IP in Selected Repository
Eitstreém [Fir xilinx.com:hls:fir:1.0 I i.
P
Add IP... ] [ Refresh Repository ]
Lok 7| cancel |[ apply
Figure 12. Setting path to IP Repositories
7-2-4. Click OK to accept the settings.
7-3. Instantiate fir_top core twice, one for each side channel, into the
processing system naming the instances as fir_left and fir_right.
7-3-1. Click the Add IP icon ‘¥ and search for FIR in the catalog by typing FIR and double-click on the
FIR entry to add an instance.
7-3-2. Click on the Add IP to Block Design button if presented.
Notice that the added IP has HLS logo in it indicating that this was created by Vivado HLS.
7-3-3. Select the added instance in the diagram, and change its instance name to fir_left by typing it in
the Name field of the Block Properties form in the left.
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7-3-4. Similarly, add another instance of the HLS IP, and name it fir_right.

7-3-5. Click on Run Connection Automation, and select /fir_left/s_axi_fir_io and click OK.

7-3-6. Similarly, click on Run Connection Automation again, and select /fir_right/ s_axi_fir_io and
click OK.

7-4. Enable the PS-PL Interrupt ports > IRQ_F2P ports. Add an instance of
concat IP with two single-bit input ports. Connect input ports to the
interrupt ports of the two FIR instances and the output port to the IRQ_F2P
port of the processing_system7_0 instance.

7-4-1. Double-click on the processing_system7_0 instance to open the re-customization form.

7-4-2. Select the Interrupt in the left pane, click on the Fabric Interrupts check box in the right.

7-4-3. Expand the Fabric Interrupts > PL-PS Interrupt Ports > IRQ_F2P entry in the right, and click the
check-box of IRQ_F2P[15:0].

7-4-4. Click OK.

7-4-5. Add an instance of the concat IP.

7-4-6. Connect the interrupt port of each of the FIR instances to the two input ports of the xlconcat_0
instance.

7-4-7. Connect the output port of the xlconcat_0 instance to the IRQ_F2P port of the
processing_system7_0 instance.

At this stage the design should look like shown below (you may have to click the regenerate
button).
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(b) Zybo
Figure 13. The complete hardware design
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7-5. Verify addresses and validate the design. Generate the system_wrapper file,
and add the provided Xilinx Design Contraints (XDC).
7-5-1. Click on the Address Editor, and expand the processing_system7_0 > Data if necessary.
The generated address map should look like as shown below.
&= Diagram X | B Address Editor X
_L'\ Ccell Slave Interface  Base Name  Offset Address Range  High Address
= =+4F processing_system7_D
23| [EHE Data (32 address bits : 4G)
e axi_gpio_0 S_AaxI Reg 0x4120_0000 64K~ 0x4120_FFFF
== zed_audio_ctrl_0 S_AXI reg0 0x43C0_0000 64K ~ 0x43C0_FFFF
e fir_left s_axi_fir_io Reg 0x43C1_0000 64K v 0x43C1_FFFF
e fir_right s_axi_fir_io Reg 0x43C2_0000 64K ¥ 0x43C2_FFFF
(a) ZedBoard
&= Diagram x | & Address Editor x iF IP Catalog x
_L'\ Cell Slave Interface Base Mame  Offset Address Range  High Address
= =4F processing_system7_0
23| EHE Data (32 address bits : 4G)
e axi_gpio_0 S _AXI Reg 0x4120_0000 64K v 0x4120 FFFF
— zybo_audio_ctrl_0 S_AXI regQ 0x6000_0000 512M =~ OxT7FFF_FFFF
- fir_left s_axi_fir_io Reg 0x43C0_0000 64K  + 0x43CO_FFFF
“mm fir_right s_axi_fir_io Reg 0x43C1_0000 64K  ~ 0x43C1_FFFF
(b) Zybo
Figure 14. Generated address map
7-5-2. Run Design Validation (Tools > Validate Design) and verify there are no errors
7-5-3. In the sources view, right-click on the block diagram file, system.bd, and select Create HDL
Wrapper to update the HDL wrapper file. When prompted, click OK with the Let Vivado manage
wrapper and auto-update option.
7-5-4. Click Add Sources in the Flow Navigator pane, select Add or Create Constraints, and click
Next.
7-5-5. Click the Add Files button, browse to the ¢:\xup\hls\labs\lab4 folder, select
zed_audio_constraints.xdc or zybo_audio_constraints.xdc
7-5-6. Click Finish to add the file.
7-5-7. Click on the Generate Bitstream in the Flow Navigator to run the synthesis, implementation, and
bitstream generation processes.
7-5-8. Click Save and Yes if prompted.
7-5-9. When the bit generation is completed, a selection box will be displayed with Open Implemented
Design option selected. Click Cancel.
v www.xilinx.com/universit Zynq 4-17
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Export to SDK and create Application Project Step 8

8-1. Export the hardware along with the generated bitstream to SDK.

8-1-1. Select File > Export > Export Hardware...

8-1-2. Make sure that Include Bitstream option is selected and click OK, leaving the target directory set
to local project directory.

8-1-3. Select File > Launch SDK

8-1-4. Click OK.

8-1-5. In SDK, select File > New > Board Support Package.

8-1-6. Click Finish with the default settings (with standalone operating system).
This will open the Software Platform Settings form showing the OS and libraries selections.

8-1-7. Click OK to accept the default settings, as we want to create a standalone_bsp_0 software
platform project without requiring any additional libraries support.
The library generator will run in the background and will create xparameters.h file in the
C:\xup\hls\labs\lab4\audio\audio.sdk\standalone_bsp_0\ps7_cortexa9_0\include\ directory.

8-1-8. Select File > New > Application Project.

8-1-9. Enter TestApp as the Project Name, and for Board Support Package, choose Use Existing
(standalone_bsp should be the only option)

8-1-10. Click Next, and select Empty Application and click Finish

8-1-11. Select TestApp in the project view, right-click the srcfolder, and select Import.

8-1-12. Expand General category and double-click on File System.

8-1-13. Browse to c:\xup\hls\labs\lab4 folder and click OK

8-1-14. Select both zed_testapp.c and zed_audio.h for ZedBoard or zybo_testapp.c and
zybo_audio.h for Zybo and click Finish to add the file to the project.
The program should compile successfully.
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Verify the Design in Hardware Step 9

9-1.

Zybo: Make sure that the JP7 is set to select USB power.

Connect a micro-usb cable between a PC and the JTAG port of the board.
Connect an audio patch cable between the Line In jack and the speaker
(headphone) out jack of a PC. Connect a headphone to the Line Out jack
(ZedBoard) or HPH OUT (Zybo) on the board. Power ON the board.

9-1-1. Zybo only: Make sure that the JP7 is set to select USB power.

9-1-2. Connect a micro-usb cable between a PC and the JTAG port of the board.

9-1-3. Connect an audio patch cable between the Line In jack and the speaker (headphone) out jack of
a PC.

9-1-4. Connect a headphone to the Line Out jack on ZedBoard or HPH Out jack on Zybo board. Power
ON the board.

9-1-5. Select Xilinx Tools > Program FPGA.

9-1-6. Make sure that the system_wrapper.bit bitstream is selected and the BMM file field is blank.

9-1-7. Click Program.
This will configure the FPGA.

9-1-8. Double-click corrupted_music_4KHz.wav or some other wave file of interest to play it using the
installed media player. Place it in the continuous play mode.

9-1-9. Right-click on the TestApp in the Project Explorer pane and select Run As > Launch On
Hardware (GDB).
The program will be downloaded and run. If you want to listen to corrupted signal then set the
SWO0 OFF. To listened the filtered signal set the SW0 ON.

9-1-10. When done, terminate the program by clicking the Terminate (Red square) button in the Console
tab of the SDK. power OFF the board, and exit SDK and Vivado using File > Exit.
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Conclusion

In this lab, you added RESOURCE directive to create an IP-XACT adapter. You generated the IP-XACT
adapter during the implementation phase. You then created a processor system using IP Integrator,
integrated the generated IP-XACT adapter, and tested the system with the provided application.

Answers

1. Answer the following questions:

Estimated clock period: 7.95 ns (ZedBoard) 6.38 ns (Zybo)
Worst case latency: 174 clock cycles (ZedBoard) 175 clock cycles (Zybo)
Number of DSP48E used: 3
Number of BRAMs used: 0
Number of FFs used: 90 168 (Zybo)
Number of LUTs used: 77 110 (Zybo)

Appendix

Create a Project using Vivado GUI Step 10

10-1. Launch Vivado and create an empty project targeting the Zedboard (having
xc7z020clg484-1 device) or Zybo (having xc7z010clg400-1 device) and
using the Verilog language.

10-1-1. Open Vivado by selecting Start > All Programs > Xilinx Design Tools > Vivado 2014.4 >
Vivado 2014.4

10-1-2. Click Create New Project to start the wizard. You will see the Create a New Vivado Project
dialog box. Click Next.

10-1-3. Click the Browse button of the Project Location field of the New Project form, browse to
c:\xup\hls\labs\lab4, and click Select.

10-1-4. Enter audio in the Project Name field. Make sure that the Create Project Subdirectory box is
checked. Click Next.
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Project Name

Enter a name for your project and specify a directory where the project data files ':\/
will be stored

Project name:

Project location: IC:/xup/hIs/Iabs/Iab4| [:]

Create project subdirectory "

Project will be created at: C:/xup/hls/labs/lab4/audio '

< Back ][ Next > ] Finish ]

I TN 7

Figure A-1. Project Name entry
10-1-5. Select RTL Project in the Project Type form, and click Next.

10-1-6. Select Verilog as the Target language and Simulator Language in the Add Sources form, and
click Next.

Add Sources

Specify HDL and netlist files, or directories containing HDL and netlist files, to add ‘:\,
to your project. Create a new source file on disk and add it to your project. You

x

[ Add Files... ] [ Add Directories... ] [ Create File... ]
Scan and add RTL include files into project
Copy sources into project !
Add sources from subdirectories (]

Target language: Simulator language:

| < Back |[ Next > ] Finish ]

Figure A-2. Add sources to new project
10-1-7. Click Next two times to skip Adding Existing IP and Add Constraints dialog boxes

10-1-8. In the Default Partform, select Boards, and either select Zedboard Zynq Evaluation and
Development Kit or Zybo. Click Next.

If you don’t see Zybo entry and wants to target Zybo board then please read readme_zybo.docx file and
install the zybo board files in the Vivado installation directory.
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¢~ New Project

Default Part

Choose a default Xilinx part or board for your project. This can be changed later.

Select: & Parts |@ Boards

4 Filter
Vendor: All v
Display Name: | All v
Board Rev: Latest v
Reset All Filters
Search: | O
Display Name Vendor Board Revewii

. Choose Zybo or ZedBoard

@ MicroZed Board em.avnet.com f
% ZedBoard Zynq Evaluation and Development Kitlem.avnet.com d

Artix-7 AC701 Evaluation Platform xilinx.com Tl
@ Basys 3 Evaluation Platform xilinx.com 1.0
@ Kintex-7 KC705 Exaluation Platform xilinx.com 1.1
<

@ xc7z010clg400-1
@ xc7z020clg484-1
@ xc7a200tfbg676-2
@ xc7a35tcpg236-1
& xc7k325tffa900-2

< Back H Next > ]

[“ zvbo ______[digilentinccomlb |\ xc72010clg400-1 {E-E!_

400
484
676
236
900

11

1 2

il

1.0

il |
=

Figure A-3. Boards and Parts selection

10-1-9. Check the Project Summary and click Finish to create an empty Vivado project.

Creating the System Using the IP Integrator

Step 12

11-1.
Cortex-A9 processor based hardware system.

11-1-1. In the Flow Navigator, click Create Block Design under IP Integrator

Flow Navigator

4 Project Manager
#3 Project Settings
¥ Add Sources
1F 1P Catalog

4 P Integrator

L% Create Block Design
B¥ Open Block Design
& Generate Block Design

Figure A-4. Create IP Integrator Block Diagram

11-1-2. Enter system for the design name and click OK

Use the IP Integrator to create a new Block Design, and generate the ARM
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11-1-3.

11-1-4.

11-1-5.

11-1-6.

11-1-7.

IP from the catalog can be added in differer = ays. Click on Add IP in the message at the top of

the Diagram panel, or click the Add IP icon in the block diagram side bar, press Ctrl + |, or
right-click anywhere in the Diagram workspace and select Add IP.

Once the IP Catalog is open, type “zy” into the Search bar, find and double click on ZYNQ7
Processing System entry, or click on the entry and hit the Enter key to add it to the design.

The Zynq block will be added.

&= Diagram x [ Address Editor x [ E
*D| %, system
b [#% Designer Assistance available. Run Block Automation
o 7
& processing_system7_0
R poR < |||
) - FIXED 104 |||
Ly M_AXI_GPO_ACLK ZYNQ M_AXI_GP0<k |||
a £ FCLK_CLKO
ﬁ FCLK_RESETO_N
i ZYNQ7 Processing System
A
Sk 3

Figure A-5. The Zynq IP Block

Notice the message at the top of the Diagram window that Designer Assistance available. Click
on Run Block Automation and select /processing_system7_0
Click OK when prompted to run automation.

Notice that external ports have been automatically added for the DDR and Fixed IO once Block
Automation has been complete; some of the other default ports are also added to the block.

processing_system7_0 processing_system7_0

PTP_ETHERNET_0 < |||

PTP_ETHERNET_0 5 |||

I
M_AXI_GPO- &
TTCO_WAVED_OUT
TTCO_WAVEL_OUT
TTCO_WAVE2_OUT
FCLK_CLKD
FCLK_RESETD_N

M_AXI_GPO_ACLK ZYNQ‘

M_AXL GPO_ACLK ZYNQ‘

DDR < [|j====f"> DDR DDR 4 [[f——> DDR
FIXED_10 4 ||f====="% FIXED_IO FIXED_10 || FIXED_IO
USBIND_0<- sp1o_04 |||

usevp_o4- ||
M_AXI_GPO<: [
TTO0_WAVED_OUT
TTCO_WAVEL_OUT
TTCO_WAVE?_OUT
FCLK_CLKD
FCLK_RESETO_N

ZYNQ? Processing System
(a) ZedBoard
Figure A-6. Zynq Block with DDR and Fixed 10 ports

ZYNQ7 Processing System

(b) Zybo

In the block diagram, double click on the Zyng block to open the Customization window for the

Zynq processing system.

A block diagram of the Zynq should now be open, showing various configurable blocks of the

Processing System.
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At this stage, the designer can click on various configurable blocks (highlighted in green) and
change the system configuration.

11-2. Configure I/O Peripherals block to use UART 1 and 12C 1 peripherals,
disabling other unwanted peripherals. Uncheck Timer 0. Enable
FCLK_CLK1, the PL fabric clock and set its frequency either to 10.000 MHz
for the ZedBoard or to 12.288 MHz for the Zybo.

11-2-1. Select the MIO Configuration tab on the left to open the configuration form and expand /O
Peripheral in the right pane.

11-2-2. Click on the check box of the I2C 1 peripheral. Uncheck USBO, SD 0, ENET 0, GPIO > GPIO
MIO as we don'’t need them.

11-2-3. Expand the Application Processing Unit group in the Select the MIO Configuration tab and
uncheck the Timer 0.

11-2-4. Select the Clock Configuration in the left pane, expand the PL Fabric Clocks entry in the right,
and click the check-box of FCLK CLK1.

11-2-5. Change the Requested Frequency value of FCLK_CLK1 to 10.000 MHz for the ZedBoard or
12.288 MHz for the Zybo.

Peripheral I/0 Fins Component Clock Source  Requested Frequ...

of | 1B

[ Processor/Memory Clocks
[ 10 Peripheral Clocks
Clock Configuration E} PL Fabric Clocks

DDR Configuration -+ V] Fok_ciko 10 PLL v | 100.000000

FCLK_CLK1 .IO FLL v. 10.000000 ‘
SMC Timing Calculation — - -

D FCLK_CLK2 IO PLL 50.000000

MIC Configuration

Interrupts - [] FeLK_cLk3 10 PLL 50

(a) ZedBoard

g =1

| Component Clock Source Requested Frequ... Actual Frequency... Range(MHz)
= [+ Timers

[+ System Debug Clocks

D FCLK_CLK3 10 PLL 30 50.000000 0.100000 : 2530.000000
D FCLK_CLK2 10 PLL 30 50.000000 0.100000 : 250.000000
FCLK_CLK1 ..IO PLL v 12.280702 0.100000 : 250.000000
FCLK_CLKO ..IO PLL v 100 100.000000 0.100000 : 250.000000

(b) Zybo
Figure A-7. Enabling and setting the frequency of FCLK_CLK1

11-2-6. Click OK.
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Notice that the Zynq block only shows the necessary ports.

11-3. Add the provided I2C-based either zed_audio_ctrl IP for the ZedBoard or
zybo_audio_ctrl IP for the Zybo to the IP Catalog

11-3-1. In the Flow Navigator pane, click IP Catalog under Project Manager.

11-3-2.

11-3-3.

The IP Catalog will open.

Flow Mavigator

==
h N SR

4 Project Manager
% Project Settings
¥ Add Sources

i} IP Catalog

4 JP Integrator
7 Create Block Design
5% open Block Design

&5 Generate Block Design

Figure A-8. Invoking IP Catalog

Click on the IP Settings button in the IP Catalog.

&= Diagram x | B Address Editor x |i{FIP Catalog x

*1| search: |
= a1
=4| Name AXI4
g
|+ Alliance Partners
NS + = Automotive & Industrial
.. | D AXI Infrastructure
= [+ BaselP
+H= Basic Elements
+[= Communication & Networking
+H= Debug & Verification
+= Digital Signal Processing
+= Embedded Processing
+ FPGA Features and Design
+ Math Functions
++= Memories & Storage Elements
El +H= Standard Bus Interfaces
+ = Video & Image Processing

Figure A-9. Invoking IP Settings

Click on the Add Repository... button. Browse to ¢:\xup\hls\labs\lab4\ip_repo directory, and

click Select.

Notice that the zed audio_ctrl and the zybo_audio_ctrl entries are displayed in the IP in Selected

Repository field.
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¢ Project Settings ﬁ

= P

yj Repository Manager | Packager

General (@ Add directories to the list of repositories. You may then add additional IP
@ to a selected repository. If an IP is disabled then a tool-tip will alert you to
Q\ the reason.

Simulation IP Repositories
@ c:/xup/his/labs{lab4ip_repo (Project)

Synthesis L :
D | Add Repository... | [ Refresh All

Implementation IP in Selected Repository

Q}T zed_audio_ctrl (xilinx.com:user:zed_audio_ctrl:1.0 )
— bo_audio_ctrl (xilinx.com:xilinx:zybo_audio_ctrl:1.0 =

Bitstream oo -
= Add IP... ] [ Refresh Repository ]

P

[ (0] ¢ H Cancel ][ Apply

Figure A-10. Adding IP repository for the provided 12C based cores

11-3-4. Click OK to accept the settings.

11-4. ZedBoard: Instantiate zed_audio_ctrl and GPIO with width of 2 bits on
channel 1 and width of 1 bit input only on channel 2.
Zybo: Instantiate zybo_audio_ctrl and GPIO with width of 1 bit output only
on channel 1 and width of 1 bit input only on channel 2.
Run connection automation to connect them.

11-4-1. Click the Add IP button 1 if the IP Catalog is not open and search for AXI GPIO in the catalog by
typing gpi and double-click on the AXI GPIO entry to add an instance.

11-4-2. Click on the Add IP to Block Design button.

11-4-3. Double-click on the added instance and the Re-Customize IP GUI will be displayed.

11-4-4. Change the Channel 1 width to 2 for the ZedBoard or width of 1 output only for the Zybo.

11-4-5. Check the Enable Dual Channel box, set the width to 1 input only, and click OK.

11-4-6. Similarly add an instance of either the zed audio_ctrl/ for the ZedBoard or the the zybo_audio ctrl
for the Zybo.
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11-4-7. Notice that Design assistance is available. Click on Run Connection Automation, and select
/axi_gpio_0/S_AXI

11-4-8. Click OK to connect it to the M_AXI_GPO interface.

Notice two additional blocks, Proc Sys Reset, and AXI Interconnect have automatically been
added to the design.

11-4-9. Similarly, click on Run Connection Automation, and select either /zed_audio_ctrl_0/S_AXI for
the ZedBoard or the /zybo_audio_ctrl_0/S_AXI for the Zybo and click OK.

11-5. Make IIC_1, GPIO, FCLK_ CLK1, and either zed_audio_ctrl or
zybo_audio_ctrl ports external.

11-5-1. Select the GPIO interface of the axi_gpio_0 instance, right-click on it and select Make External to
create an external port. This will create the external port named GPI/O and connect it to the
peripheral.

11-5-2. Select the GPIO2 interface of the axi_gpio_0 instance, right-click on it and select Make External
to create the external port.

11-5-3. Similarly, selecting one port at a time either of the zed_audio_ctrl_0 instance or the
zybo_audio_ctrl_0 instance, make them external.

11-5-4. Similarly, make the IIC_1 interface and FCLK_CLK1 port of the processing_system7 0 instance
external.

At this stage the design should look like shown below (you may have to click the regenerate [ @]

button).
processing_system?7_0
[ DDR
[ FIXED_IO
= [ 1C_1
M_AXI_GPO_ACLK ZYNQ
FCLK_CLK1 {3 FCLK_CLK1
FCLK_RESETO_N F__
ZYNQ? Processing System
SDATA [ axi_gpio_0
rst_processing_system7_0_100M processing_system?7_0_axi_periph
| s AXT
aislowst_sync_dk mb_reset - Sﬂﬁ i > Ta; T GPIO<E "—| 3 GPIO
ext_reset_in bus_struct_reset[0:0] =i ., S0+ | e GPIO2
aux_reset_in peripheral_reset{ 0:0] RESETN
mb_debug_sys rst  interconnect_aresetn[0:0] <00 ACLK (5] 5] AXI GPIO
dem_locked periphera\_alﬁetn[ﬂ:ﬂ]‘ Sﬂﬁ_aRESETN D§D MOD_AXI<p _. zed_audio_ctrl_0
o MOL_AXI . e o
Processor System Reset MOOACK  minm L ol BCK—— [T BCLK
f—— MOO_ARESETN (SDATA_I LRCLK LRCLK
S —
MO1_ACLK S_AXI_ACLK
= i SDATA Op—————————— [
j—101_ARESETN 5 AXI_ARESETN * =DATA-O
AXI Interconnect zed_audio_ctr

Figure A-11. Block design after 12C based zed_audio_ctrl core added and connections
made for the ZedBoard
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processing_system?_0

'—D DDR
FIXED_IO
- Ic.1
M_AXI_GPO_ACLK ZYNO B
{5 FCLK_CLK:
FCLK_RESETO_N pm—1t
ZYNQ7 Processing System
RECDAT
[ axi_gpio_0
rst_processing_system?7_0_100M processing_system7_0_axi_periph
< RS _AXI
slowest_sync_ck mb_reset = i soo AXT 2 4:; o GPIO | T GPIO
ext_reset_in bus_struct_reset[0:0]m w ol areser 102 > GPI02
=—(aux_reset_in peripheral_reset[0:0]pm= RESETN Sl
=mb_debug sys_rst  interconnect_aresetn[0:0] mmml cwack E—HE AXI GPIO
={dcm_locked peripheral_aresetn[0:0] _ARESETN = DMDG,AXH% —- zybo_audio_ctrl_0
i MOL_AXI o |y .
Processor System Reset MOO_ACLK  mdam > +o| S AXT BCLK| -—D BCLK
MOD_ARESETN RECDAT PBLRCIKE——————————{ 3 PBLRCLK
MOL_ACLK S_AXT_ACLK RECLRCLK {3 RECLRCLK
MO1_ARESETN S_AXI_ARESETN  PBDATA—————[ ™ PBDATA
AXT Interconnect Zybo_audio_ctr

Figure A-11. Block design after 12C based zybo_audio_ctrl core added and connections
made for the Zybo
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