UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 13225

4.2i ISE - Error: "The module <aaa> in the file <xxx.vhd> conflicts with the module <aaa> in the file <yyy.vhd>...."

描述

Keywords: 4.1i, ISE, package, component, module, JHD, VHDL, conflict

Urgency: Standard

General Description:
The following error is reported:

"The module <mod_name> in the file <xxx.vhd> conflicts with the module <mod_name> in the file <yyy.vhd>. The definition must be resolved before processes will be available for the source."

When HDL files are added to an ISE project that has a user-created Package file, the component in the Package file is added to each HDL file as a component. (This occurs regardless of whether a library declaration is made in the HDL file.)

解决方案

To work around this problem, open the .jhd files that correspond to the .vhd files reported in the error message in a text editor. Modify the .jhd files manually by deleting the component declaration where it is not used.

This issue was fixed in the 5.1i software.
AR# 13225
日期 08/11/2003
状态 Archive
Type 综合文章
的页面