UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 15961

LogiCORE Pipelined Divider v2.0 - Why do I get could not find divider_v2_0 for functional simulation or the Pipelined Divider from Coregen?

描述

Keywords: Coregen, Divider, Pipelined. v2.0, dividervht, dividervht_v2_0, XilinxCoreLib

Urgency: standard

General Description:
When doing functional simulation using 5.1i on the Coregen Pipelined Divider v2.0 using the generated .vhd wrapper file and the 5.1i XilinxCoreLib ModelSim gives the following error:
# ** Error: (vcom-11) Could not find C:/Modeltech_5.6b/Xilinx_lib/XilinxCoreLib.dividervht_v2_0.

解决方案

The 5.1i XilinxCoreLib library is actually called dividervht not called dividervht_v2_0.

In the vhd wrapper file the line:
for all : wrapped_divd2 use entity XilinxCoreLib.dividervht_v2_0(behavioral)
needs to be changed to:
for all : wrapped_divd2 use entity XilinxCoreLib.dividervht

This is a regression, and is fixed in 5.2i.
AR# 15961
日期 07/26/2007
状态 Archive
Type 综合文章
的页面