UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 30456

10.1 EDK - "ERROR:MDT - Error while performing Cygwin checks..."

描述

Keywords: XPS, Cygwin, Checks, launch

The following error occurs when I attempt to launch XPS:

"Xilinx EDK detected Cygwin installation v1.5.25(0.156/4/2) on your machine.
But, this Cygwin (C:\\tools\\cygwin/bin) cannot be used to run Xilinx EDK tools.
Xilinx EDK tools require a Cygwin installation that is not newer than v1.5.24(0.156/4/2).
ERROR:MDT - Error while performing Cygwin checks....
ERROR: creating XPS module failed!"

How can I use Cygwin 1.5.25 or newer?

解决方案

The only version of Cygwin that is supported is the one that is shipped with EDK.

To work around this problem, set XILINX_EDK_DISABLE_CYGWIN_CHECK=1.

In Windows:
1. Right-click on My Computer.
2. Select Properties.
3. Select the Advanced tab.
4. Select Environment Variables.
5. Under System Variables, select New.
6. Add: XILINX_EDK_DISABLE_CYGWIN_CHECK (with a value of 1).

Starting in Service Pack 1, 1.5.25 will now be the upper limit for the Cygwin check.
This problem has been fixed in the latest EDK 10.1 Service Pack, available at:
http://www.xilinx.com/xlnx/xil_sw_updates_home.jsp
The first service pack containing the fix is EDK 10.1 Service Pack 1.
AR# 30456
日期 02/01/2009
状态 Active
Type 综合文章
的页面