UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 4026

M1.5, M1.4 MAP, COREGEN - ERROR:x4kma:387 - Unable to obey design constraints which require the combination of the following symbols into a single CLB: on RLOC'd Coregen RAM, FIFO's

Description

Keywords: map, x4kma, 387, constraints, rloc, RAM, fifo, Coregen

Urgency: standard

General Description: map gives the following error related to RLOC'd RAM including RAM generated by the CORE Generator:

ERROR:x4kma:312 - The following symbols could not be constrained to a single
CLB:
DFF symbol
"fpga_core_i_cu_ram_r256x8_i/r256x8/ablock/large_ram_we0/newSim1535/dff"
(output signal=fpga_core_i_cu_ram_r256x8_i/ablock/dcode_0)
FMAP symbol
"fpga_core_i_cu_ram_r256x8_i/r256x8/ablock/large_ram_we0/dcodeslice_0func/newS
im1534" (output
signal=fpga_core_i_cu_ram_r256x8_i/ablock/large_ram_we0/dcode_in_0)
HMAP symbol
"fpga_core_i_cu_ram_r256x8_i/r256x8/ablock/large_ram_we0/newSim1539" (output
signal=fpga_core_i_cu_ram_r256x8_i/ablock/dwe_0)
FMAP symbol "fpga_core_i_G_1220" (output signal=fpga_core_i_us_cm_we)
More than two combinational outputs are required. These symbols share the
same RLOC attribute value, which requires them to be mapped to the same CLB.

解决方案

This problem is fixed in the latest M1.4 Core Tools Update
available on the Xilinx Download Area:

Solaris: http://www.xilinx.com/txpatches/pub/swhelp/M1.4_alliance/core_sol17_m14.tar.Z
SunOS http://www.xilinx.com/txpatches/pub/swhelp/M1.4_alliance/core_sun17_m14.tar.Z
HPUX: http://www.xilinx.com/txpatches/pub/swhelp/M1.4_alliance/core_hp17_m14.tar.Z
Win95/NT: http://www.xilinx.com/txpatches/pub/swhelp/M1.4_alliance/core_nt17.zip

NOTE: For this issue, the environment variable XIL_MAP_NO_FMAP_PACK
must be set in addition to installing the appropriate software update.
For M1.5, the Sevice Pack must be installed for the
environment variable to work. For M1.4, the latest
Core Tools Update must be installed.


setenv XIL_MAP_NO_FMAP_PACK (SunOS and Solaris)
setenv XIL_MAP_NO_FMAP_PACK 1 (HP)
set XIL_MAP_NO_FMAP_PACK = 1 (PC)
AR# 4026
创建日期 06/03/1998
Last Updated 09/09/1999
状态 Archive
Type 综合文章