UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 50492

14.1 CompXlib - This version of the compiler is incompatible with the library .dat file.

描述

When compiling the EDK libraries with ModelSim, a number of errors are produced similar to the following:

** Error: /build/si10/EDK_P.15xf/env/Databases/IP3_hw_04240158/QA/P/EDK_P.15xf/output/export/processor/hardware/pcores/xps_usb2_device_v7_00_a/hdl/vhdl/dre.vhd(385): near "0.0": This version of the compiler is incompatible with the library .dat file.
** Error: /build/si10/EDK_P.15xf/env/Databases/IP3_hw_04240158/QA/P/EDK_P.15xf/output/export/processor/hardware/pcores/xps_usb2_device_v7_00_a/hdl/vhdl/dre.vhd(385): near "0.0": This version of the compiler is incompatible with the library .dat file.
** Error: /build/si10/EDK_P.15xf/env/Databases/IP3_hw_04240158/QA/P/EDK_P.15xf/output/export/processor/hardware/pcores/xps_usb2_device_v7_00_a/hdl/vhdl/dre.vhd(385): VHDL Compiler exiting

What is the reason for this?

解决方案

These error occur when an unsupported version of ModelSim is being used. 

This has been seen with both ModelSim 6.6d and ModelSim 10.0a.

Please ensure that you are using a supported version of the simulator for a given ISE release. 

See the following document for supported versions in 14.1.

http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_1/irn.pdf

Errors do not occurs when ModelSim 10.1a is used.

 

 

链接问答记录

主要问答记录

Answer Number 问答标题 问题版本 已解决问题的版本
50493 14.1 CompXlib GUI does not list the correct Simulator versions N/A N/A
AR# 50492
日期 11/06/2014
状态 Active
Type 综合文章
Tools
  • ISE Design Suite - 14
的页面