UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 6002

V1.5i CORE Generator - Unsatisfied link error encountered on startup

Description

Keywords: CORE Generator, COREGen, start, unsatisfied link, 1.5i, 1.5, 1.4

Urgency: Standard

General Description:
When I invoke CORE Generator, I encounter the following error:

java.lang.UnsatisfiedLinkError: setBackground
at sun.awt.motif.MComponentPeer.initialize(Compiled Code)
at sun.awt.motif.MComponentPeer.<init>(Compiled Code)
at sun.awt.motif.MCanvasPeer.<init>(Compiled Code)
at sun.awt.motif.MPanelPeer.<init>(Compiled Code)
at sun.awt.motif.MFramePeer.<init>(Compiled Code)
at sun.awt.motif.MToolkit.createFrame(Compiled Code)
at java.awt.Frame.addNotify(Compiled Code)
at java.awt.Window.show(Compiled Code)
at xilinx.xworks.gui.MainFrame.<init>(Compiled Code)
at xilinx.xworks.builder.Xworks.init(Compiled Code)
at xilinx.xworks.builder.Xworks.main(Compiled Code)

CORE Generator ultimately fails to start up.

解决方案

This problem has been seen when the location of another Java installation
is specified in the user's LD_LIBRARY_PATH environment variable.

To correct this situation, set the LD_LIBRARY_PATH environment variable
to <install_dir>/java1.1.3/lib before invoking CORE Generator on WorkStation platforms.

On WorkStations:

setenv LD_LIBRARY_PATH <install_dir>/java1.1.3/lib


On PC's:

Add the following line to the beginning of <install_dir>/coregen/bin/win/coregen.bat:

set LD_LIBRARY_PATH = <install_dir>/java1.1.3/lib
AR# 6002
创建日期 08/31/2007
Last Updated 02/15/2001
状态 Archive
Type ??????