UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 655

Orcad - Using Orcad Capture with XACT

Description


General Description:

How do I use Orcad Capture with XACT?

解决方案


Using Orcad Capture v6.1 or later with XACT 5.x or XACTstep 6.x:



1. Use Capture to create the schematic.

2. Create INF netlists for the design from within the Capture environment.

3. Use SDT2XNF to translate the INF files to XNF files.

4. Process the XNF files through either XMAKE or the XACTstep Design Manager.



When you need to add properties/attributes to components, it is important that the

properties be named the same way they would be by default in SDT. The only user

properties which will translate back into an INF file are the default Part Value names

in SDT such as 1ST PART FIELD, 2ND PART FIELD, 3RD PART FIELD, etc.

(This is case-sensitive.)



For example, suppose you wish to put a location attribute on an OPAD to lock it to

Pin 14. To add this attribute in SDT 386+, you would place the cursor over the OPAD,

and select Edit -> Edit -> Loc, Options -> Name; you would then type the line

"LOC=P14."



In Orcad Capture, the translators do not recognize the Xilinx part field names such as

"LOC, OPTIONS" (or OPTIONS_1 for XC4000 designs). Capture can translate the

default SDT 386+ Part Field names as previously mentioned, so we can take advantage

of this in order to place the same location attribute on an OPAD in Capture.



To do this, select the OPAD; then, from the menu bar, select Edit -> Properties. A dialog

box will appear, and you should click on the "User Properties" button. Another dialog

box will come up; click on the "New" button. A third dialog box will appear; in the name

field, type 1ST PART FIELD (Remember: capitalization counts!). In the value field, type

"LOC=P14."



Select the OK button on each of the three dialog boxes, and the attribute will be successfully

added.



Below is a listing of the SDT part field names and their corresponding Orcad Capture property

names. This might be useful as you start using the interface.



Capture Property..........XC2000/XC3000..........XC4000



1ST PART FIELD........LOC, OPTIONS............OPTIONS_1

2ND PART FIELD.......BLKNM.........................OPTIONS_2

3RD PART FIELD.......BASE.............................INIT

4TH PART FIELD.......CONFIG.........................BASE

5TH PART FIELD.......EQUATE_F...................CONFIG

6TH PART FIELD.......$FCONT........................EQUATE_F

7TH PART FIELD.......EQUATE_G...................EQUATE_G

8TH PART FIELD.......EQUATE_H



Using Orcad Capture v6.0 with XACT 5.x or XACTstep 6.x:



The best method is to update ORCAD CAPTURE to 6.1 or later; if this is not possible,

the following methodology has been successful on some designs:



XACT's Orcad interface was originally designed for use with Orcad SDT 386+ version 1.1.

Since the release of Orcad capture for Windows, the following methodology has been

determined to work with the XACT software. It will require use of the annotate.exe and

inet.exe executables from the SDT 386+ ORCADEXE directory, as well as the SDT.CFG

file from your ORCAD\TEMPLATE directory. If you do not have a copy of these files, contact

Orcad technical support to have them provided.



CREATING NEW DESIGNS IN ORCAD CAPTURE



LIBRARY CONVERSION



The libraries you need to translate from SDT format to Orcad Capture format are:



For XC2000 designs --> \XACT\XC2000\XC2000.LIB

For XC3000 designs --> \XACT\XC3000\XC3000.LIB (also add XBLOX.LIB for 3KA designs)

For XC4000 designs --> \XACT\XC4000\XC4000.LIB

For XC7000 designs --> \XACT\XC7000\XC7000.LIB



To translate one of these libraries:



Start Orcad Capture. From the menu bar select File --> Open --> Library, and a dialog box will

pop up. In the lower left-hand corner, a selection that says "List files of Type" will be set by

default to Orcad Capture Library (*.OLB). Change this to SDT Libraries (*.LIB). Select the

Xilinx Library you wish to translate, and click the OK button.



A new dialog box that says "Save Translated Library As..." should appear. (This can be anything

you like, but it is a good idea to use the default name.) After you select the OK button, it begins

translating. This generally takes a few minutes. When it completes, a window containing all of the

library symbols appears.



Select File --> Close. You have now translated the Library to Orcad Capture format.



DESIGN ENTRY



In order to start entering the design, you need to remove any default libraries that

Orcad Capture uses, and point to the translated Xilinx unified libraries. To swap the

libraries, select Place --> Part, and a new dialog box will appear on the screen.

Select all of the libraries already configured, and click on the Remove Library button.

Then, browse to the correct Xilinx Unified library directory, select each of the

libraries you need for the design, and click on the Add Library button.



Use the Orcad capture program to add components and nets to the design. When

you need to add properties/attributes to components, it is important that the properties

be named the same way they would be by default in SDT. The only user properties that

will translate back to a .SCH file are the default Part Value names in SDT (such as 1ST

PART FIELD, 2ND PART FIELD, 3RD PART FIELD, etc.).



For example, suppose you wish to put a location attribute on an OPAD to lock it to Pin 14.

To add this attribute in SDT 386+, you would place the cursor over the OPAD, select Edit

--> Edit -> Loc, Options -->Name; then, type the line "LOC=P14."



In Orcad Capture, the translators do not recognize the Xilinx part field names such as

"LOC, OPTIONS" (or OPTIONS_1 for XC4000 designs). However, the translator tools can

translate the default SDT 386+ Part Field names as previously mentioned, so we can take

advantage of this in order to place the same location attribute on an OPAD in Orcad Capture.



To do this, select the OPAD; then, from the menu bar, select Edit --> Properties. A dialog box

will appear; click on the "User Properties" button. Another dialog box will come up in front of the

original box; click on the "New" button. A third dialog box will appear; in the name field, type

1ST PART FIELD (Remember: capitalization counts!). In the value field, type "LOC=P14."



Select the OK button on each of the three dialog boxes, and the attribute will be successfully added.



Below is a listing of the SDT part field names and their corresponding Orcad Capture property names.

This might be useful as you start using the interface.



Capture Property..........XC2000/XC3000..........XC4000



1ST PART FIELD........LOC, OPTIONS............OPTIONS_1

2ND PART FIELD.......BLKNM.........................OPTIONS_2

3RD PART FIELD.......BASE.............................INIT

4TH PART FIELD.......CONFIG.........................BASE

5TH PART FIELD.......EQUATE_F...................CONFIG

6TH PART FIELD.......$FCONT........................EQUATE_F

7TH PART FIELD.......EQUATE_G...................EQUATE_G

8TH PART FIELD.......EQUATE_H



SAVING IN SDT FORMAT



Once you have entered the design, you will need to save it as a .SCH file so that the Xilinx interface

will be able to process it. Save the design; then, in the Design Window, select the schematic folder

and File --> Save As... from the menu bar. A new dialog box will appear. Change "Saved File" type

from Capture Design (*.DSN) to SDT 386+ (*.SCH). Then, change the name of the file you're saving

to have a .SCH extension and select the OK button. You now have a SDT-compatible SCH file that

can be used to work with the Xilinx interface.



COMPILING THE DESIGN



Quit Orcad Capture, and open a DOS window. Copy the SDT.CFG file from the ORCAD\

TEMPLATE directory to the directory in which you saved the schematic; then, run XDRAFT #

(where # is the first digit of the family for which you are translating the design; for example, in

an XC4000 design, you would type "XDRAFT 4"). Next, run XMAKE on the SDT schematic

you just made, and Xilinx tools will place and route your design.



MIGRATING EXISTING XILINX DESIGNS TO ORCAD CAPTURE



We currently recommend that you finish existing designs in SDT 386+ before migrating to

Orcad Capture, as the translation process can lose attributes that are not specified as 1ST

PART FIELD... If you must move to Orcad Capture immediately, remember that the only

property names that will currently translate from Orcad capture to SDT files are the PART

FIELD properties.
AR# 655
创建日期 08/31/2007
Last Updated 08/15/2011
状态 Archive
Type 综合文章