AR# 71590

Zynq UltraScale+ MPSoC - Video Codec Unit (VCU) - Why do I get an error saying that the omxh264enc, omxh265enc, omxh264dec or omxh265dec cannot be found when running a GStreamer pipeline?

描述

Why do I get an error saying that the omxh264enc, omxh265enc, omxh265dec or omxh264dec cannot be found when running a GStreamer pipeline?

WARNING: erroneous pipeline: no element omxh264dec (or omxh264enc).

Running gst-inspect-1.0 /usr/lib/gstreamer-1.0/libgstomx.so shows the expected name/description/version/etc info for gst-omx, but indicates that it has 0 features (i.e no plugins available) instead of the expected features omxh264enc, omxh265enc, omxh264dec and/or omxh265dec.

解决方案

If you are seeing the above error, make sure that you have included /etc/xdg/gstomx.conf in your root filesystem.

This file tells gst-omx where to find the OMX integration layer library libOMX.allegro.core.so.1.

链接问答记录

主要问答记录

AR# 71590
日期 10/16/2018
状态 Active
Type 综合文章
器件
Tools
IP