AR# 73275

PetaLinux - Zynq UltraScale+ MPSoC VCU - Why Do I see OpenSSL errors when RTMP is enabled in the 2019.1 or 2019.2 VCU TRD in gstreamer1.0-plugins-bad?

描述

Why Do I see OpenSSL errors when RTMP is enabled in the 2019.1 or 20192 VCU TRD in gstreamer1.0-plugins-bad?


project-spec/meta-user/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
PACKAGECONFIG_append = " rtmp"

ERROR: gstreamer1.0-plugins-bad-1.14.4+gitAUTOINC+ec1ff1219c-r0 do_prepare_recipe_sysroot: The file /usr/include/openssl/e_os2.h is installed by both openssl10 and openssl, aborting

ERROR: gstreamer1.0-plugins-bad-1.14.4+gitAUTOINC+ec1ff1219c-r0 do_prepare_recipe_sysroot: Function failed: extend_recipe_sysroot

解决方案

By default, gstreamer1.0-plugins-bad enables dtls, which depends on openssl:

PACKAGECONFIG[dtls] = "-enable-dtls,-disable-dtls,openssl"


rtmp is also enabled in gstreamer1.0-plugins-bad. 

rtmp depends on rtmpdump.

PACKAGECONFIG[rtmp] = "-enable-rtmp,-disable-rtmp,rtmpdump"


rtmpdump depends on openssl10. (Not openssl)

DEPENDS = "openssl10 zlib"


Openssl and openssl10 both install the same header files and libraries.

As a result there is a compilation error when we enable rtmp in gstreamer1.0-plugins-bad.


This is a known issue while trying to enable the RTMP package in a Yocto build (which has a dependency on openssl10).

This issue is fixed upstream by changing RTMP recipes to use GnuTLS instead of OpenSSL10, which resolves the issue.

  • 2019.1 - Users can download the PetaLinux Recipes and Patch files from (Xilinx Answer 72324) to work around this issue
  • 2019.2 - Users can download the PetaLinux Recipes and Patch files from (Xilinx Answer 73019) to work around this issue
  • 2020.1 - This issue will be resolved in the 2020.1 release and later versions

链接问答记录

主要问答记录

AR# 73275
日期 01/25/2020
状态 Active
Type 已知问题
器件
Tools
IP
Boards & Kits