UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

AR# 7513

CoolRunner/XPLA Professional Simulator - Why doesn't the simulator use the *.scl file when a signal is not recognized?

描述

Keywords: WebPACK, XPLA, Professional, CoolRunner, fitter, simulator, scl

Urgency: Standard

General Description:
Why doesn't the simulator use the *.scl file if a signal in the file is not recognized?

解决方案

When loading an SCL file, if the simulator sees a signal that it does not recognize, none of the SCL file is loaded and the simulator reverts to a "blank" SCL file. This can happen when an internal node is displayed in the Functional Simulator and added to the SCL file.

Then when a Timing Simulation is performed, the internal node may have collapsed and may no longer exist, therefore, this signal is not recognized by the simulator, so the simulator loads a "blank" SCL. This is an SCL file with the I/O signals present and with no stimulus defined.

The work-around is to save the SCL file containing the internal node as some other file name using either Windows Explorer or the Functional Simulator. Then, in the Functional Simulator, remove the internal node. The SCL file without the internal node can then be used in the Timing Simulator.
AR# 7513
日期 05/25/2001
状态 Archive
Type 综合文章
的页面