AR# 75482

|

HDMI 2.0 Transmitter (TX) Subsystem - Why do some monitors not show the HDR ON label while playing HDR content?

描述

Why do some monitors not show the HDR ON label while playing HDR content?

In this example we are using the following design:

Zynq UltraScale+ MPSoC VCU TRD 2020.1 - PL DDR HDR10 HDMI Video Capture and Display

With some HDR compatible monitors, when trying to play HDR content from a media player, the HDR ON label does not come up on the display.

In the display settings it shows Emulated HDR.

The below gstreamer pipeline is from testing on the ZCU106 evaluation board:

gst-launch-1.0 v4l2src device=/dev/video0 io-mode=4 hdr-mode=1 ! video/x-raw, width=3840, height=2160, format=NV16_10LE32, framerate=60/1 ! omxh265enc qp-mode=auto gop-mode=basic gop-length=60 b-frames=0 target-bitrate=60000 max-picture-size=1100 num-slices=8 control-rate=constant prefetch-buffer=true low-bandwidth=false filler-data=true cpb-size=1000 initial-delay=500 ! video/x-h265, profile=main-422-10, alignment=au ! queue ! omxh265dec internal-entropy-buffers=5 low-latency=0 ! queue max-size-bytes=0 ! fpsdisplaysink text-overlay=false video-sink="kmssink bus-id="a00c0000.v_mix" plane-id=33 sync=true hdr-mode=1" sync=true

解决方案

This is a known issue for the HDMI TX 2020.1 DRM drivers which can be resolved using the attached patches.

Please unzip the attached directory inside of the following path in the PetaLinux project and run the Petalinux-build command.

/<plnx-proj-root>/project-spec/meta-user/recipes-kernel

附件

文件名 文件大小 File Type
2020_07_31_AR75482_HDR10_BUG_FIX.zip 18 KB ZIP

链接问答记录

主要问答记录

Answer Number 问答标题 问题版本 已解决问题的版本
65911 HDMI 1.4/2.0 Transmitter (TX) Subsystem - Release Notes and Known Issues for the Vivado 2015.4 tool and later versions N/A N/A
AR# 75482
日期 09/10/2020
状态 Active
Type 已知问题
器件
Tools
IP
Boards & Kits
People Also Viewed