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 Click Cancel to close the Simulation Options dialog box. 5.

 Click Launch, and wait for ISim to open.  6.

 

Figure 20: Running ISim for Behavioral Simulation 

You can explore the ISim environment at this time. Refer to the ISim In-Depth Tutorial 

(UG682), for information about using ISim.  

 Close the ISim window by using the File > Exit command from the main menu.  7.

 Click Yes to confirm closing the tool if necessary. 8.

  

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=ug682.pdf
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Step 4: Elaborating and Analyzing the RTL Design 

The PlanAhead tool provides RTL elaboration capabilities to compile RTL source files in the 

project. Once elaborated, the RTL views enable cross-selection of logic objects. Displayed 

compilation errors and warnings are cross-selectable to module definition or instantiation lines 

in the RTL code. The RTL logic hierarchy is expanded and available for analysis. Opening the RTL 

Design from the Flow Navigator automatically elaborates the RTL design and displays the 

Design Analysis view layout. 

 The RTL Netlist and Hierarchy views display the logic hierarchy of the design.  

 The RTL Schematic enables interactive logic exploration.  

 The Find command enables searching of RTL logic objects.  

 The Instance Properties view displays information about the selected logic instantiation 

including resource estimation.  

 The RTL DRCs highlight potential areas of the design to improve power or performance. 

Elaborating and Opening the RTL Design 

 Under RTL Analysis in the Flow Navigator, select Open Elaborated Design. 1.

 If prompted, click OK in the Warnings dialog. 2.

The RTL Design is elaborated and opened. 

 Click the Messages view tab  and click the Collapse All toolbar button 3.

 Expand the Elaborated Design folder, and scroll through the various messages associated 4.

with the open_rtl_design command. 

 

Figure 21: Viewing RTL Elaboration Messages 
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Examining the RTL Netlist and Hierarchy 

 In the RTL Netlist view, expand the usbEngine0 instance by clicking the plus sign (+). 1.

 Select the usbEngine0/u0 instance. 2.

 In the RTL Netlist view, right-click to open the popup menu, and select the Go to Definition 3.

popup command. 

The RTL file usbf_utmi_if.v opens in the Text Editor. This is the RTL code that defines the 

UTMI Interface module. The file opens to the line containing the usbf_utmi_if module 

definition.  

 

Figure 22: RTL Netlist - Go to Definition 

 In the RTL Netlist view, right-click and select the Go to Instantiation popup command.  4.

The RTL file usbf_top.v opens to the line containing the usbf_utmi_if instance. 

 In the RTL Netlist view, right-click and select the Show Hierarchy popup command. 5.

The RTL Hierarchy view opens with the usbEngine0/u0 module selected. The modules 

display with blocks sized relative to the amount of logic contained in them, making it easy to 

locate large modules. 
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Figure 23: Hierarchy View 

 To close the RTL Hierarchy, click X on the view tab.  6.

 To close the Text Editor, click X on all open RTL files. 7.

Traversing the Schematic 

 In the RTL Netlist view, expand and select the usbEngine0/u0/u0 instance (the level below 1.

the previous selection). 

 In the RTL Netlist view, click the Schematic button to open the schematic window.  2.

You can also right-click and select the Schematic command from the popup menu.  
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Figure 24: RTL Schematic 

 Double-click the LineState[1:0] pin on the outside of the u0 module to expand the 3.

schematic outward from the pin as shown in Figure 20. 

For additional schematic exploration capabilities, see the Design Analysis and Floorplanning 

Tutorial: PlanAhead Design Tool (UG676). 

 

TIP: Click and drag using the left mouse button in the RTL Schematic view from the lower right to 

the upper left to use the Zoom Fit command. 

 Select the LineState_r instance in the RTL Schematic view. 4.

 In the Schematic view, right-click to open the popup menu and select the Go to 5.

Instantiation to go to the selected logic instance in the usbf_top.v file.  

 

http://www.xilinx.com/cgi-bin/docs/rdoc?v=14.5;d=PlanAhead_Tutorial_Design_Analysis_Floorplan.pdf
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Figure 25: Expanding Logic 

 Close the various open Text Editor, Hierarchy, and Schematic windows. 6.

 In the RTL Netlist view, click the Collapse All button .  7.

Using the Find Command 

 Click the Find button in the main toolbar , or select Edit > Find to open the Find dialog 1.

box. 

 

Figure 26: Using Find 
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 Examine the Find filter options.  2.

 Set the Criteria to Type > is > Block Memory, and click OK. 3.

The Find Results view opens to display the results of the find operation.  

 

Figure 27: Find Results 

 Select one of the Block RAMs in the Find Results; right-click to open the popup menu and 4.

select Go to Instantiation. 

The instance is selected in the RTL Netlist view and displayed in the Text Editor. 

 Close the Find Results view and the Text Editor. 5.
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Step 5: Estimating Resource Utilization 

With the elaborated RTL Design opened, you can begin to examine the resource requirements 

of the design. The Project Summary provides a view of the Resources required by the design at 

each step in the design flow. Obviously the estimation of required resources in the RTL design is 

going to be less accurate than the resources utilized by the synthesized or implemented design, 

but it does begin to offer some insight into the requirements of the design.  

 In the Project Summary, select the Run Report RTL Utilization command. 1.

The RTL Resource Estimation opens in the Project Summary. 

 In the RTL Netlist view, select top. 2.

 In the Netlist Properties view, select the Statistics tab. 3.

 

Figure 28: RTL Resource Utilization 

The RTL Macro Resources displays in the Netlist Properties view, as shown in Figure 20. If the 

Netlist Properties view is not displayed, select Window > Properties from the main menu. 
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Figure 29: RTL Netlist Property Statistics 

 Scroll down the Netlist Properties view to examine the various categories of statistics. 4.

 RTL Macro Resources 

 RTL Hierarchy Resources 

 RTL Primitive Statistics 

 RTL Memory Resources 

 Net Boundary Statistics 

 Clock Report 

 In the RTL Netlist view, select other modules and examine the statistics in the Properties view 5.

for those selected modules.  

Notice that the Netlist Properties view has changed to the Instance Properties view for the 

selected modules. This is because you are no longer viewing the top-level of the design. The 

statistics presented in the Properties view are now for the resources required by the module, 

rather than for the whole design. 

  



 Step 6: Running RTL Design Rule Checks 

RTL Design and IP Generation Tutorial  www.xilinx.com  31 

UG675(v14.5) April 10, 2013 

Step 6: Running RTL Design Rule Checks 

PlanAhead provides Design Rule Checks (DRC) that can be run on the RTL Design. These include 

LINT-style RTL checks for power or performance improvement suggestions. There are basic I/O 

bank and voltage rules for the RTL Design also. After the design is synthesized, a more 

comprehensive set of logic design, I/O, and clock DRCs is available for the Synthesized Design. 

 From the Flow Navigator, select Report DRC. 1.

 In the Run DRC dialog box, expand and examine the RTL rules, and click OK. 2.

 

Figure 30: Running DRC 

The DRC Results view opens as shown in Figure 31. 
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Figure 31: DRC Report 

 The DRC Results viewer color codes messages as follows: 3.

 Errors with a red icon 

 Critical Warnings with an orange icon 

 Warnings with a yellow icon 

 Informational messages with a blue icon 

 Select the UCIO #1 latch warning in the violations list. 4.

The Violation Properties view displays with information about the violation and links to 

select the offending logic objects.  

 Close the DRC Results view. 5.

 Close the RTL Design by clicking the Close X icon in the Elaborated Design banner. Click OK 6.

in the confirmation dialog box if needed. 

Step 7: Selecting IP from the Xilinx IP Catalog 

The PlanAhead tool is integrated with the CORE Generator™ tool to provide an IP Catalog with 

search and filtering capabilities. This allows you to easily find the desired IP. You can customize, 

instantiate and implement the core into your FPGA design from within the PlanAhead tool. You 

can access the IP Catalog from the Project Manager and Elaborated Design environments. 

Opening and Searching the IP Catalog  

 Select IP Catalog from the Flow Navigator. 1.

 Expand some of the IP categories. 2.

 Select any IP and explore the available toolbar buttons and popup menu commands. 3.



 Step 7: Selecting IP from the Xilinx IP Catalog 

RTL Design and IP Generation Tutorial  www.xilinx.com  33 

UG675(v14.5) April 10, 2013 

 

Figure 32: Browsing the IP Catalog 

The Details for a selected IP display at the bottom of the IP Catalog view. By default, only the 

most recent version of the IP supported for the target device family is displayed.  

You can change the list of IP cores listed in the catalog by enabling and disabling commands 

on the toolbar menu of the IP Catalog view. 

 To view all IP in the catalog, toggle the Hide Superseded and Discontinued IPs  button 4.

and the Hide Incompatible IPs button  .  

 To view a flattened list of IP, disable the Group by Category toolbar button . 5.

 Type fir in the Search field at the top of the view. 6.

 Select a FIR Compiler IP. 7.

The details of the IP core are displayed in the Details panel at the bottom of the IP Catalog 

view. 

 From the popup menu, select the Data Sheet command. 8.

This will open a PDF view of the datasheet for the selected IP core. Examine the datasheet, 

and close the PDF viewer when finished. 

 Clear the Search field to expand the Catalog list. 9.
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Customizing an IP Core 

 Enable the Group by Category button.   1.

 Click the Collapse All button   in the IP Catalog toolbar menu. 2.

 Expand the Math Functions > Adders & Subtracters folder.  3.

 Double-click the Adder Subtracter to run the Customize IP command. 4.

This opens the Customize IP dialog box for the selected core, as shown in Figure 33. This is 

the interface to the CORE Generator™ software in the PlanAhead tool. Different IP will 

display different dialog boxes for customization.  

Examine the different fields and information available in the Customize IP dialog box. 

 In the B Input Width field, type 18. 5.

 Click Generate. 6.

Clicking Generate has a different effect when launched from PlanAhead than when run from 

CORE Generator standalone.  

 In standalone mode, the CORE Generator™ software automatically launches XST to 

synthesize the IP core.  

 When launched from the PlanAhead tool, the synthesis step is not run automatically. This 

lets you instantiate and configure multiple IP cores into your RTL design before 

launching synthesis. You can synthesize the IP as part of the overall design, or synthesize 

it standalone as a block of the design. 

When the Adder Subtracter core has been generated, it is added to the design, and listed 

under the IP Sources tab of the Sources view. In addition, since a new source has been 

added to the design, the Elaborated Design is shown as being out-of-date and must be 

reloaded, but first the new IP core must be instantiated into the design.  
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Figure 33: Customizing IP 

Instantiating the IP Core 

At this time, the Adder Subtracter core definition is added to the project files, and is available for 

use in the design. However, the core has not yet been integrated into the design. At this time 

you will create an instance of the IP in the RTL design.  

 In the upper right of the Elaborated Design banner, click the ‘X’ button to close the design. 1.

 In the Sources view, select the IP Sources tab and click the Expand All button.  2.

 Double-click the c_addsub_v11_0_0.veo file to open the instantiation template in the Text 3.

Editor. 
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Figure 34: Viewing the Instantiation Template 

 Select the text in the Text Editor, starting just below the line labeled “Begin Cut here…” 4.

and ending at the line with “//INST_TAG_END”.  

 Click the Copy Text button. 5.

The copied text can easily be pasted into any RTL source file to instantiate the IP module 

into your design.  

With the IP instantiated into your design, the IP can be synthesized along with the rest of the 

design, or as a standalone module. You can also generate the simulation files required to 

simulate the IP core as part of the design.  

 Select the c_addsub_v11_0_0 IP core from any tab in the Source view.  6.

 Right-click to open the popup menu and select the Generate Output Products command.  7.

The Manage Output Products dialog box opens as is shown in Figure 35. This lets you 

generate the specific files needed to support the IP core in the overall design.  
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Figure 35: Manage IP Output Files 

 Examine the dialog box, and then close it. 8.

You can also change the parameters of an IP core by selecting it in the Sources view and 

using the Re-customize IP command from the popup menu. This will open the Customize IP 

dialog box as was seen previously in Figure 33.  

 Close the .veo instantiation template file in the Text Editor. 9.

 Close the IP Catalog. 10.

 Select File > Exit. If prompted, click No to save and OK to close PlanAhead. 11.
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Conclusion 

In this tutorial, you: 

 Used a small RTL project to examine the PlanAhead RTL development and analysis 

environment. 

 Started by creating an RTL project, explored RTL sources and the RTL editor.  

 Ran behavioral simulation, elaborated the RTL design, and explored the analysis capabilities, 

which included examining the RTL logic hierarchy, RTL schematic exploration, searching for 

logic types, reviewing RTL resource and running RTL DRCs.  

 Examined the Xilinx IP Catalog, and customized, and instantiated a small adder IP core. 

 

 


